Uploading from Garmin Connect to Garmin Forerunner 410

I have just got a new Garmin Forerunner 410 and have not been able to transfer routes, workouts etc. from Garmin Connect to the 410 using my Mac. (Downloading from the 410 to Garmin Connect is working fine) When you export an item it says the export has worked but on the 410 it says no data found.

ANT+ agent, Garmin Communicator plug-in and the 410 firmware are all up to date versions. This problem still exists with the new 2.30 version of the 410 firmware released today.

I have searched the Garmin forums and lots of other people seem to be having the same issues.

I have tried using various browsers - Safari, Firefox and Opera - which all say that Garmin Communicator is working. People had solved the problem with Google Chrome in the past but the current version will not even work with the Communicator plug-in. The Garmin website says that all these browsers should work.

I don't know if this is just an issue on Mac computers. 

Anyone out there solved this issue or having the same problem ?



  • The Communicator plug-in is flaky, especially in Chrome if you're running a 64-bit version of OSX with a 64-bit browser.  I have to resort to Firefox at the moment.

    The plug-in, by the way, has always been flaky on OSX, usually because the browser-sniffer was written to work with a range of browsers (v8-v15, for example), rather than the those from a certain point onwards.

  • Tried all these things and spent hours messing about but never did the fist rule of the IT helpdesk. Turned the computer off and on again. It all works now !

  • When you got the Mac did you download the version of Garmin Connect for Macs (not windows). You need to do this before putting the USB in. This will faff around, and then it will recognise it and ask you to log in. Then you need to put your watch, switched on, in range. On the watch it will confirm that you want to connect it to the device. Then it should upload the data.

    Was my first time doing it this morning, onto a PC though. Worked a treat. I use Google Chrome btw.

  • It was fine downloading to Garmin Connect, it was uploading from Garmin Connect that was the problem. On the Garmin website lots of other people were having the same issue.

    As you may see from my second post I have now fixed the issue by rebooting my Mac. Must have got its knickers in a twist and this sorted them out. All is fine and dandy and I can now even upload my runs to Fetch Everyone as well.

    I used to work in an IT department and this was always the first thing to try when things went perar shaped. I didn't listen to my own knowledge. Hey ho.

  • "Download from" = transfer data from Connect to the watch/PC

    "Upload to" = transfer data from the watch/PC to Connect


    Next time it happens check Activity Monitor and kill the Communicator Plug-in process.

  • Just brough a 410 and had exactly the same problem on my MAc, thanks HalfRunnerHalfBiscuit, spent all evening trying to get it to work then read this forum ............ exactly the same problem rebooted the MAc and all is well Cheers


Sign In or Register to comment.