Garmin 910 elevation not working?

Hey all, my garmin 910 xt elevation reading doesn't seem to work.  it shows a true elevation reading when in dormant mode ie on but not pressed start yet.

but as soon as I press start the elevation sticks at something like 65.62, and doesn't show the proper elevation graph when uploaded.  

PI tried a complete system reset and still same.  I also have not been able to upload the new garmin 2.8 version for some reason, no idea why.

written to garmin a couple of days ago buno heard nothing.

if anyone has same problem then be great to hear from you.

cheers,  TT. image

Comments

  • have you tried to recalibrate it as opposed to a system reset, failing that have a look on the back and youll see a hole near on of the screws - make sure you havent got crap in it. and i suppose you already been on the garmin forums 

     

  • Thanks DK, will have a look at the screws tonight.  it just seems strange cos my mates got same and his is doing exact same thing??....weird

    image

  • Couldn't seem to open that IR?

  • Ok do a search in garmin correction 65.62 slow twitch and you should get to the same article 

  • Thanks for that IR, and having followed that......yes it is faulty!   Doing IMUK next Sunday, so time to phone garmin!

  • i've had the same problem about 4 times in the past year - each time it has been swapped out and then the replacement has lasted about 3 months. My current one is knackered and Garmin have just agreed to replace it again because of all the problems I've had even though I am now out of warranty. 

    Anyway if you push them hard enough - and pay a deposit up front - they'll ship you a new one before you return the faulty one. You really have to push for this but I've got them to do it twice now.

Sign In or Register to comment.