Garmin 410 - Activity Transfer to Garmin Connect Failed


After about 7 months of problem free use of my Garmin 410, I've now hit an issue. On Sunday, I was trying to upload the last couple of days' activities from my watch to Garmin Connect via the USB Ant Stick, and all seemed to be progressing normally, but at the end under Data Transfer Status, it came up with 'Activity transfer to Garmin Connect failed'.

Tried again, by creating a dummy activity, but had the same message, and when logging into the Garmin Connect site, I noticed it was actually down for maintenance.

Didn't bother again on Sunday, but tried again after my next run on Tuesday and had the same problem.

Since then, I have tried: -

1. Forcing an upload.

2. Soft reset and forcing an upload.

3. Deleting Old Activities and forcing an upload.

4. Deleting other activities already uploaded and forcing an upload.

5. Manually adding individual activities to Garmin Connect that preceded the problem, deleting them from the watch and trying another forced upload of more recent activities.

6. Deleting all activities on the watch.

7. And finally, have just tried a hard reset, set the watch up again from scratch, and after creating a dummy activity that has failed as well.


Completely out of ideas now.

The Garmin Agent program is recognising the USB Stick - currently reading 'Active' and 'Waiting for new data', and indeed seems to connect ok to the watch, transfer the activity as per normal, but then at the end has this message 'Activity Transfer to Garmin Connect failed.'

Anyone had a similar issue, and if so did you / how did you manage to solve it?



  • I think it just uploads them later, when it can. Last week I uploaded some data from the watch to the stick, only for the transfer to the website to fail, but if I look now, all my runs are on the website. I didn't do anything to make that happen.

  • Thanks Chris.

    Think there might be something in that - have finally managed to solve it - not all of the below steps will necessarily be relevant, but worth detailing here in case anyone else has a similar problem.

    1.) I'd previously checked whether pairing was still working, and it was.

    2.) Nevertheless, felt it was probably worth unpairing and repairing the device.

    3.) Tried to force an upload again, and was prompted to sign in with my Username/Password.

    4.) This time I got a 'Network Error 2'.

    5.) Googled that and it was suggested that it might be because Internet Explorer had gone offline - even though my default browser is Chrome.

    6.) Opened IE, opened a webpage, which returned the message 'IE went online to open the requested page.'

    7.) Forced another upload - and voila! Success.

    It might be that 6.) in this post is all that was required for me in this instance, but thought I'd complete the full trail so if anyone else searches thanks to a similar problem they have a full check list of things to try!

    Ho-hum. There's a few hours of my life I'll never get back, but might save others some pain.


  • Hey BBB, that's a coincidence, as I had the same problem with my 610xt after a password change. Took me ages to sort it, and eventually found out about the IE thing the same time as you. Garmjn customer services were no help at all!

  • Hello Bus. Aye, I've read some scathing reviews of Garmin customer services, so shied away from that option!

    This has happened to me again a couple of times again since, and think I may have got to the bottom of it now, though it's still a mystery why it's just started causing an issue with the Garmin.

    Some time ago I'd set a temporary dial up connection on my laptop for some diagnostics at work, and the IE settings on this were 'Dial whenever a network connection is not present'. If the laptop was not connected physically to a network, or not in range of a working wi-fi it knew about, seems that it was attempting to dial up that old connection - and that it's probably that which was then causing IE to work offline.

    Hopefully it won't reoccur for you, but if it does - check that!

  • It happened to me once. I can't remember what I did about it, but whatever it was seems to have worked. Hope that helps. image

  • Supremely helpful, Lit - thanks! image

Sign In or Register to comment.